XenForo 2.2.7 inadvertently shipped with an implicit minimum requirement of PHP 7.1 due to the way that newer versions of composer attempt to validate your platform is compatible with the included dependencies.

If you're currently running PHP 7.0 you may have been unable to upgrade to or run XenForo 2.2.7. Patch 1 removes this platform check.

Additionally, if you're currently running PHP 7.0 we would strongly urge you to consider upgrading to a newer version as soon as possible. XenForo 2.3 will be shipping with a minimum requirement of PHP 7.2.5. We currently recommend upgrading to PHP 8.0 where possible.